Maintained by: NLnet Labs

unbound listening sporadically on 0.0.0.0 high ports when configured for 127.0.0.1 ?

Paul Wouters
Fri Jun 3 01:13:39 CEST 2016


On Fri, 3 Jun 2016, Daisuke HIGASHI wrote:

> Subject: Re: unbound listening sporadically on 0.0.0.0 high ports when
>     configured for 127.0.0.1 ?

>   My guess is: UDP sockets for outgoing query
> from Unbound to authoritative servers.
>
>  I also see these "listening" UDP sockets at my laptop running unbound
> when resolver is under load. And I see no them when no load.

That was my first thought too, but these entries do not have a
destination IP or port, so it "appears" that these sockets are
listening. Still it could be that perhaps these are sockets
that are starting up for use or something?

Paul

> --
> Daisuke HIGASHI
>
>
> 2016-06-03 0:34 GMT+09:00 Paul Wouters via Unbound-users
> <unbound-users at unbound.net>:
>>
>> See https://bugzilla.redhat.com/show_bug.cgi?id=1342105
>>
>>         from time to time "netstat -l" shows unbound listening on some
>> high-ports not
>>         bound to 127.0.0.1 - that makes no sense when the service is
>> configured for
>>         127.0.0.1 only as a local resolver on a inbound mailfilter
>>
>>         udp        0      0 0.0.0.0:42663           0.0.0.0:*
>>         563/unbound
>>         udp        0      0 127.0.0.1:53            0.0.0.0:*
>>         563/unbound
>>         udp        0      0 0.0.0.0:12387           0.0.0.0:*
>>         563/unbound
>>
>>         unbound.conf
>>          interface: 127.0.0.1
>>          access-control: 127.0.0.0/8 allow
>>          interface-automatic: no
>>
>> Paul
>