Maintained by: NLnet Labs

[Unbound-users] Troubleshooting occasional "Permission denied" errors?

Tom Samplonius
Tue Jun 16 09:14:42 CEST 2015


  I’m seeing some Permission denied errors in the log:

Jun 15 19:51:56 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 20:02:03 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 20:19:51 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 20:32:35 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 20:55:43 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:00:05 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:25:44 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:30:26 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:33:38 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:41:51 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:48:41 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 21:52:04 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 22:00:55 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 22:01:56 dns2 unbound: [18520:1] error: can't bind socket: Permission denied
Jun 15 22:03:38 dns2 unbound: [18520:1] error: can't bind socket: Permission denied


Unbound seems to be running normally, and appears to be answer all queries normally.  It is version 1.4.20 on CentOS 7.

I suspect it may be a conflict between the random port algorithm and something else running on this server, though I don’t know what it could be.  The error message would be more helpful if it included a port number and possibly the source IP.  I have not set outgoing_interface, or made any changes to the port selection options, so Unbound is using defaults.

How do I track this down?  Would version 1.5.3 fix this?  1.4.20 is from CentOS 7 base repo.  


Tom