Maintained by: NLnet Labs

[Unbound-users] patches to also build with Python 3.x

Pavel Simerda
Wed Sep 17 12:04:27 CEST 2014


Hi,

I started working on getting unbound work with Python 3.x and here are the first results. With the attached patches, the unbound source code still builds with Python 2.x but also builds with Python 3.x.

To test it, you need to configure the sources to build all the python stuff:

./configure --with-pythonmodule --with-pyunbound

So far I tested on Gentoo with the exact command above, as /usr/bin/python is Python 3.x by default. I also tested it using a live Gentoo ebuild[1] and I'm going to build it for Fedora[2] as part of the feature to use Python 3.x as the default implementation on Fedora[3].

[1] https://github.com/okias/ixit/blob/master/net-dns/unbound/unbound-9999.ebuild
[2] https://bugzilla.redhat.com/show_bug.cgi?id=1115489
[3] https://fedoraproject.org/wiki/Changes/Python_3_as_Default

Note that the two patches represent the minimal changes needed to *build* unbound with Python 3.x, that doesn't say whether the successful build will also *work* properly, it is just the first step for it. Next step will be to identify the issues that arise.

Cheers,

Pavel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0001-configure-don-t-choke-when-built-Python-3.x.patch
Type: text/x-patch
Size: 15426 bytes
Desc: not available
URL: <https://unbound.nlnetlabs.nl/pipermail/unbound-users/attachments/20140917/4007afd6/attachment.bin>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0002-use-Python-3.x-API-correctly.patch
Type: text/x-patch
Size: 2750 bytes
Desc: not available
URL: <https://unbound.nlnetlabs.nl/pipermail/unbound-users/attachments/20140917/4007afd6/attachment-0001.bin>