Maintained by: NLnet Labs

[Unbound-users] timeout and transitioning error

Michel Blais
Mon Oct 22 19:40:18 CEST 2012


Hello,

I just installed unbound and now trying it in production after first 
local test seem fine.

Now that the're some load on it, we now see several timeout (around 1 
every 30 requests) and lot of error in log but can't find this error on 
google.

unbound[54539:1] error: transitioning to response state sans response

This was writen in log around 101086 times maybe 30 minutes.

OS is FreeBSD 9.0, net.inet.icmp.icmplim have been raise so dmesg don't 
report any error about this. I know this sysctl can affect bind so I 
raised it. Unbound version is the one on paquage so 1.4.13

I tryed to start it with -v -d but no error are shown on screen.

config :

--------------- config start ----------------
server:

     verbosity: 1
     logfile: /usr/local/etc/unbound/unbound.log

     interface: 0.0.0.0
     port: 53

     do-ip4: yes
     do-ip6: no
     do-udp: yes
     do-tcp: yes

     access-control: 0.0.0.0/0 allow_snoop

     hide-version: yes
     harden-glue: yes

     cache-min-ttl: 3600
     cache-max-ttl: 86400

     prefetch: yes

     num-threads: 3

     msg-cache-slabs: 4
     rrset-cache-slabs: 4
     infra-cache-slabs: 4
     key-cache-slabs: 4

     rrset-cache-size: 128m
     msg-cache-size: 64m

     unwanted-reply-threshold: 10000
     do-not-query-localhost: no
     val-clean-additional: yes

    forward-zone:
          name: "."
          forward-addr: 8.8.8.8
          forward-addr: 8.8.4.4
          forward-addr: 4.2.2.1
          forward-addr: 4.2.2.2
          forward-addr: 4.2.2.3
          forward-addr: 4.2.2.4
          forward-addr: 4.2.2.5
          forward-addr: 4.2.2.6

  stub-zone:
         name: "ourdomain.com"
         stub-addr: 127.0.0.1 at customnsdport

    stub-zone:
         name: "ourseconddomain.com"
         stub-addr: 127.0.0.1 at customnsdport

    stub-zone:
         name: "W.X.Z.in-addr.arpa"
         stub-addr: 127.0.0.1 at customnsdport

    stub-zone:
         name: "Y.X.Z.in-addr.arpa"
         stub-addr: 127.0.0.1 at customnsdport
----------------- config end ----------------------

I serched a lot the error but can find anything.

Anybody able to help.

Thanks

Michel