Maintained by: NLnet Labs

[Unbound-users] Packets lost when multi threading

W.C.A. Wijngaards
Fri Dec 7 11:50:04 CET 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Leo,

On 12/07/2012 11:29 AM, Leo Baltus wrote:
> Hi,
> 
> When I run unbound multi-threaded perf keeps reporting 'Packets
> lost', but when it runs single threaded it does not.
> 
> $ perf -d 10 -a 'www.omroep.nl IN A' 2a02:458:101:31::34 qps:
> 29262.9 qps: 31986.4 qps: 32167.5 qps: 32479.7 qps: 33064.3 qps:
> 32174.4 qps: 31408.1 qps: 35887.4 qps: 37471.3 qps: 35364.5 overall
> time: 	10.0001 sec Packets lost: 	732 0(NOERROR): 	331249 replies 
> average qps: 	33124.5
> 
> This is unbound-1.4.18 with openssl-1.0.0j, ldns-1.6.16 and 
> libevent-2.0.21-stable running on a linux-2.6.27.59 kernel.
> 
> It even reports this when perf is run on the host running unbound.
> 
> Is this a known issue?

No.  Can you try setting so-rcvbuf higher (4m) ?  It may be lost
simply because it is out of buffers.  There is nothing intrinsic in
unbound that makes it drop packets in this setup; it must be the OS.

Best regards,
   Wouter


-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.18 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJQwcncAAoJEJ9vHC1+BF+NchIQAIZAvwKs+ZBSGc/QFiVF7Rrs
ShDGG4QX2tq21DDUwmPJEdo5sfUQD5GkbHwfXCNSLkEoa/2icp2IazdYts0XOJfF
H81OrDWqwM8gzofCQkeAGszlCEhdJzdxu9oMqfmN/YC6hItmWRiCmZA38kCrHLVo
WTTo8HyO8OmjfIB1ItEglLKUMxKdbrccRncqjC95SbgOiDPgwRqx2FtKVcxzlWZe
JBiLZsRLV3g1ticGxe3EVJUkYTKT/OjWQhk3v+dtGm3ckX4kjj3oSdl6j0b5OY5o
++aAjcOPGNqSpergDSgkGcxwpMLWQKTWXDlHcnoEXqwVx4oFZCpe9bS/ws5l4oli
lz8qXbv+auid6fcI+pUCIh1+PBLmpcJfntlyTnxS16vfp8tf2K1U+S0AaV6c4njc
+kekHt0PwOXCg5ysW5XDmUzSy94nKJK37QO212tM8acfkohAHSzN+rFxqRCiAzO/
aGMKQlAEkzDV+nA9rkf6BhrA0TqqO1FF7ft784H+tvM+C2bib8gf70UnWu4k6rJd
TQ061YJ9ej5tM6NnhQX3GlHDN9jkwL1GamTSQlAV3pk7sW2m1lkV5n9rLpNan4Bn
yV541hNZKm+LDq1dEGwKcbK18lslgFEkKc633yE3xujZIbgNDLzDhMXrZWi9uouA
zZ+757Rd3hE0SN1kNWJl
=IjBl
-----END PGP SIGNATURE-----