Maintained by: NLnet Labs

[Unbound-users] Problems running Unbound-1.4.0 on FreeBSD 7.2-STABLE and 9.0-CURRENT

Sergey Matveychuk
Mon Nov 30 21:11:27 CET 2009


Dmitriy Demidov wrote:
> Hello.
> 
> I have a problems with new Unbound-1.4.0. 
> 
> I'm using FreeBSD 7.2-STABLE and 9.0-CURRENT:
> FreeBSD hius.local.home 7.2-STABLE FreeBSD 7.2-STABLE #0: Sat Aug 15 13:49:47 EEST 2009     terminus at hius.local.home:/usr/obj/usr/src/sys/STABLE  i386
> FreeBSD dune.local.home 9.0-CURRENT FreeBSD 9.0-CURRENT #0: Wed Nov 18 19:43:21 EET 2009     terminus at dune.local.home:/usr/obj/usr/src/sys/CURRENT  amd64
> 
> I can not run Unbound-1.4.0 on them - it just crashes. Previos Unbound version worked on STABLE without any problems.
> I have been tested Unbound with/without libevent, and with/without threads on STABLE - no success.
> On CURRENT I been tested default configuration of port (threads+libevent).
> 
> 
> 
> 
> $ pkg_info | grep unbound
> unbound-1.4.0       A validating, recursive, and caching DNS resolver
> $ pkg_info | grep libevent
> libevent-1.4.12     Provides an API to execute callback functions on certain ev

It's easy to fix changing line
module-config: "iterator"
with
module-config: "validator iterator"

-- 
Dixi.
Sem.