Maintained by: NLnet Labs

[Unbound-users] Using pyunbound with chaos

Ondřej Surý
Tue Jun 16 14:15:14 CEST 2009


Do you run bind9 on same machine? 9.6.1 is bind9 version...

Ondrej.

On Tue, Jun 16, 2009 at 13:47, Chris Hills<chaz at chaz6.com> wrote:
> Hi
>
> The command `dig +short @::1 version.bind. chaos txt` outputs "9.6.1". The
> following python script however outputs "None":-
>
> import unbound
> ctx = unbound.ub_ctx()
> ctx.set_fwd("::1")
> status, result = ctx.resolve("version.bind", unbound.RR_TYPE_TXT,
> unbound.RR_CLASS_CH)
> print result.rawdata
>
> I am using Unbound 1.3.0 on GNU/Linux with Python 2.5.2.
>
> Regards,
>
> Chris
>
> _______________________________________________
> Unbound-users mailing list
> Unbound-users at unbound.net
> http://unbound.nlnetlabs.nl/mailman/listinfo/unbound-users
>



-- 
Ondřej Surý <ondrej at sury.org>
http://blog.rfc1925.org/